Monday, March 26, 2007

My iaStor Problem Solved!

Disabling the on board Realtek RTL8187 Wireless device and uninstalling its Vista x64 device driver has resolved the iaStor timeout problems on Nighthawk.

After 14 hours without a single iaStor timeout problem, Nighthawk was shutdown, all USB ports (except for the Realtek RTL8187 Wireless device) enabled in BIOS, and Vista Ultimate x64 restarted. Nighthawk has now been running in this configuration for over 36 hours without a single iaStor timeout problem.

Why did I disable the USB ports to begin with?

The on board Realtek RTL8187 Wireless device is actually a USB device!

The USB Universal Host Controller 2831 uses the same IRQ as the Intel(R) 82801HR/HH/HO SATA RAID Controller - 13 (19). The USB and USB2 Universal Host Controllers also utilize memory resources right next to the memory resources allocated to the Intel(R) 82801HR/HH/HO SATA RAID Controller (more commonly known as the Intel ICH8R Controller.)

In fact, the memory resources allocated to the Intel(R) 82801HR/HH/HO SATA RAID Controller start at address FEBFF800, which immediately follows where the memory resources allocated to the USB2 Universal Host Controller 2836 ends at address FEBFF7FF.

A poorly written driver for a USB2 devices, e.g., the Realtek RTL8187 Wireless device, can easily cause a problem for the Intel ICH8R Controller if it writes outside its allocated address space, even by just one address location!

ASUS has just released ASUS WiFi-AP Solo driver V1285-7.3.13.0 for VISTA 32bit/64bit, a beta driver. I am not going to touch it. Fortunately for me, I have no need for the on board Realtek RTL8187 Wireless device.

2 comments:

Robert said...

Wow, very impressive diagnostic. I have to wonder, why are you putting up with all this trouble Vista is causing you? It seems you would have saved an enormous amount of time sticking with XP (or even better, Ubuntu).

lastrider said...

Interesting blog, I came across this post while I was searching for solutions to my woes...

I have a ASUS P5N32 SLI Premium with ASUS WIFI SOLO. Vista shows the Realtek RTL8187 Device, unfortunetly I can't find any suitable drivers for Vista. I've tried many from both realtek and ASUS however none work.

Here's me hoping you could lend a helping hand. :p